Mittwoch , 21 August 2019
Startseite » Featured » WordPress 3.0: Neuer Multiblog wird fehlerhaft angezeigt

WordPress 3.0: Neuer Multiblog wird fehlerhaft angezeigt

Wordpress PluginViele kennen dieses Problem vielleicht, andere wiederum nicht. Man hat sich mit einer WordPress Installation das Multiblog Netzwerk eingerichtet, so dass man auf einer Domain mehrere Blogs mit eigenen Inhalten und Rechten auf Subdomains (subdomain.meinblog.de) oder zusätzlichen Verzeichnissen (meinblog.de/verzeichnis) anlegen kann. Einen eigenen Artikel zum Thema „WordPress: Multiblog Netzwerk einrichten“ habe ich dazu bereits verfasst. Das Problem welches nach oder während der Installation des Multiblog Netzwerkes auftreten kann ist folgendes: Man soll in der Anleitung unter anderem einen Code-Schnipsel in die .htaccess auf dem Server einfügen. Nun werden aber einige einen Fehler bekommen, denn die .htaccess Datei lässt sich nicht ändern. Beziehungsweise wird die .htaccess nach einer lokalen Bearbeitung nicht abgeändert auf den Server zurückübertragen. Man erhält einen kritischen Fehler oder eine kritische Dateiübertragung. Die htaccess bleibt auf dem Server die alte. Demzufolge wird unser neuer (zusätzlicher) Blog auf der Subdomain oder auf dem neuen Verzeichnis nicht korrekt dargestellt. Das Theme fehlt komplett, wird quasi gar nicht angezeigt, und das Administrationsmenü des neuen Blogs ist nicht erreichbar.

Wie also bekommen wir den Code-Schnipsel in die htaccess Datei? Im Grunde genommen ist es ganz einfach. So einfach, dass man erstmal darauf kommen muss! Man erstellt sich einfach eine neue htaccess Datei! Da wir alte Code-Zeilen in der htaccess sowieso nicht mehr benötigen (in 99,9% der Fälle sind die alten Regeln im neuen Codeschnipsel enthalten), können wir das einfach machen. Zur Sicherheit behalten wir die alte htaccess Datei und benennen sie einfach um. Ich habe sie zum Beispiel .htaccessALT genannt. Dann erstellen wir auf unserem PC eine neue Datei, z.B eine Textdatei namens „htaccess.txt“. In dieser Textdatei fügen wir den Codeschnipsel, den wir von WordPress vorgegeben bekommen haben, ein und speichern die Datei ab. Nun laden wir die htaccess.txt in den gleichen Ordner auf den Server, wo auch unsere alte htaccess Datei liegt. Zu guter Letzt müssen wir die htaccess.txt nur noch in .htaccess umbenennen und das war es!

Nun sollte das Theme wieder angezeigt und das Administrationsmenü von eurem neuen Blog erreichbar sein! Vorrausgesetzt ihr habt auch den Rest der Installtion richtig gemacht. Das jedenfalls war mein Problem, welches ich beim Erstellen eines neuen Multiblogs in WordPress hatte. Ich hoffe geholfen zu haben.

Weitere Problemlösungen, Hilfen und Quellen:

http://wemaflo.net/tutorial-wordpress-3-0-eine-installation-fuer-viele-blogs-nutzen.html

http://forum.wordpress-deutschland.org/konfiguration/69274-htaccess-nicht-ueberschreibbar-kritischer-fehler.html

WordPress 3.0: Neuer Multiblog wird fehlerhaft angezeigt
4.62 (92.31%) 13 Artikel bewerten

Über Patrick Stuhlemmer

Vater, Griller, Fussballfan, Kinogänger, Serienjunkie, Produkttester, Leseratte, Blogger, Kaffeetrinker, Kaufempfehler. Seit Januar 2009 mit Weblog-Deluxe im "Neuland" vertreten. Vorsicht: Beiträge könnten Ironie oder Sarkasmus trotz fehlender Smileys beinhalten! ;-) Ihr findet mich auch auf Google+ oder Twitter